Back to overview
Maintenance

Data migration & servers maintenance

Apr 4, 2026 at 6:45pm UTC  –  Apr 6, 2026 at 7:38pm UTC
Affected services
app.mentionlab.io
api.mentionlab.io

Resolved
Apr 6, 2026 at 7:38pm UTC

The maintenance is done.

Created
Apr 4, 2026 at 6:45pm UTC

Heads up - we're taking the platform offline this weekend for an infrastructure upgrade. It's one of those necessary steps to keep things fast and reliable for you.

🗓 Saturday 4 April → Monday 6 April during the day
📍 Impact: The platform will be fully unavailable during this window